Вы всегда должны устанавливать последнюю доступную версию расширения, потому что в новых версиях расширения появляются новые функции, но что важнее - исправляются ошибки работы расширения.

Также, иногда, провайдеры данных (такие как Instagram, Facebook, YouTube, и др.) меняют свой код таким образом, что некоторые функции расширения, а иногда и все расширение целиком перестает работать. В этом случае я выпускаю новую версию расширения, в которой эти изменения учтены и она послностью работоспособна. И если вы не обновите установленную версию - она просто не будет работать.

Как проверить есть ли новая версия расширения можно прочитать тут: Как проверить есть ли новая версия расширения